Antique Tractors Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an allis wd that I just got over the summer. It has been working fine. But now the starter will not engage. I Just got the starter back from the shop where they rebuilt it. They gave it new brushes, bushings and turned the strater? They also redid the switch. It bench tests fine. I went over the wiring and replaces each wire one at a time so it has all new wires. I cannot get the starter to engage at all not even a little click, whine or grind. Just nothing. I have tried the key in both positions. The fues in the switch cover is good. What am I missing? What can I test to find where this is not working? The lights work when the switch is turned on. It is not in gear. It gave me some trouble one time but when I tapped on the starter it started working again. Any suggestions? This one has me stumped...

Korey
 

·
Administrator
Joined
·
4,107 Posts
That tractor should have the battery cable directly to the manual starter switch on the starter.
If it works on the bench but not the tractor, make sure everything is clean (not rusty) where the nose goes into the motor,
and the dimple where the set screw fits, as well as the set screw. That's where they get their ground.
 

·
Registered
Joined
·
1 Posts
I have an allis wd that I just got over the summer. It has been working fine. But now the starter will not engage. I Just got the starter back from the shop where they rebuilt it. They gave it new brushes, bushings and turned the strater? They also redid the switch. It bench tests fine. I went over the wiring and replaces each wire one at a time so it has all new wires. I cannot get the starter to engage at all not even a little click, whine or grind. Just nothing. I have tried the key in both positions. The fues in the switch cover is good. What am I missing? What can I test to find where this is not working? The lights work when the switch is turned on. It is not in gear. It gave me some trouble one time but when I tapped on the starter it started working again. Any suggestions? This one has me stumped...

Korey
I had a similar experience and replacing the battery cables fixed it. They didn't look that bad but they surely were very old and apparently weren't getting the job done. Not clear to me if you meant "replacing wires" included battery cables. Just a suggestion ..
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I had a similar experience and replacing the battery cables fixed it. They didn't look that bad but they surely were very old and apparently weren't getting the job done. Not clear to me if you meant "replacing wires" included battery cables. Just a suggestion ..
Thank you for the tips. It turned out it was the negative cable to the frame that had a bad connection. It was good enough to run the light but not good enough for the starter. I also cleaned the old grease off the starter where it mounts to the tractor so it might have been that as well or most likely a combination of both. It is never just one thing... :LOL
 

·
Administrator
Joined
·
4,107 Posts
Glad you found the problem and it's working properly.
Thanks for letting us know what you found.
 
  • Like
Reactions: 2 Bs
1 - 5 of 5 Posts
Top